login with administratrative account
su -
pkginfo -i SUNWarc SUNWbtool SUNWhea SUNWlibC SUNWlibms SUNWsprot SUNWtoo SUNWi1of SUNWi1cs SUNWi15cs SUNWxwfnt
svccfg -s application/pkg/server setprop pkg/inst_root=/media/SOL_11_1_REPO_FULL/repo
svcadm refresh application/pkg/server
svcadm enable application/pkg/server
pkg set-publisher -G '*' -g /media/SOL_11_1_REPO_FULL/repo solaris
pkg install SUNWhea
pkg install SUNWi1of
pkg install SUNWi1cs
pkg install SUNWi15cs
pkg install SUNWxwfnt
groupadd oinstall
groupadd dba
groupadd oper
/usr/sbin/useradd -d /export/home/oracle -m -s /bin/bash -g oinstall -G dba oracle
passwd oracle
ulimit -Sa
ulimit -Ha
mkdir -p /u01/app/oracle
mkdir -p /u02/oradata
chown -R oracle:oinstall /u01/app/oracle/
chown -R oracle:oinstall /u02/oradata/
chmod -R 775 /u01/app/oracle
chmod -R 775 /u02/oradata
login as oracle
xhost +
export DISPLAY=:0
export AWT_TOOLKIT=XToolkit
Friday, January 24, 2014
Change hostname on Solaris 11
To change the hostname in Solaris 11, I followed this steps:
1 - To check the current environment properties:
1 - To check the current environment properties:
root@solaris:~# svccfg -s system/identity:node listprop config config application config/enable_mapping boolean true config/nodename astring solaris config/loopback astring solaris2 - Set the new hostname
root@solaris:~# svccfg -s system/identity:node setprop config/nodename="my-host-name" root@solaris:~# svccfg -s system/identity:node setprop config/loopback="my-host-name"3- Refresh the properties:
root@solaris:~# svccfg -s system/identity:node refresh4 - Restart the service:
root@solaris:~# svcadm restart system/identity:node5 - verify that the changes took place:
root@solaris:~# svccfg -s system/identity:node listprop config config application config/enable_mapping boolean true config/nodename astring my-host-name config/loopback astring my-host-name
root@solaris:~# hostname my-host-nameThe hostname in the prompt will appear the next time a shell is open.
Monday, January 20, 2014
Change Hostname on Solaris 10
1. create a file /etc/init.d/set_hostname with below content
HOSTNAME=`cat /etc/nodename` echo "Setting hostname to $HOSTNAME... \c" uname -S $HOSTNAME echo "Done."
2. create a symbolic link as /etc/rc2.d/S70set_hostname
ln -s /etc/init.d/set_hostname /etc/rc2.d/S70set_hostname
Subscribe to:
Posts (Atom)